tinyurl.com/36zdbe -> discuss.fogcreek.com/joelonsoftware4/default.asp?cmd=show&ixPost=142517
Do you all have coding standards that require the programmer to write more for the sake of readability? David Seruyange Tuesday, May 18, 2004 I have to admit, it takes a couple seconds to figure out what's going on, but I wouldn't have a hissy over it. Walt Tuesday, May 18, 2004 I think the addition of a few spaces makes it an order of magnitude more readable at first glance, but maybe it's just me: int move = eCommandName == "UP" ? Sometimes helps if you put it in brackets like so and space them a bit better: bar = (foo == 23 ? Imagine if instead of a literal you had: int move = eCommandName == eTagValue ? The question isn't necessarily what it does - the question is: "Are what it does, what I think it does, and what the coder intended all the same thing?" Putting in the parentheses goes a long way towards answering that question. Philo Philo Tuesday, May 18, 2004 The only time we approve ternary is if the 'then/else' part is simple (eg the -1:1 in your case). The last thing I want to see is stuff like: foo = bar == 'joe' ? We don't use the ternary operator, because of readability concerns. In our work, we have software products that are maintained occasionally over periods of 10-15 years. Frequently, the development environment or computer language used vanishes while the product is still economically viable. Our customers are frustrated if we cannot support the software while they can make money selling systems including the software. I am frustrated as well, since selling an old product that is well tested and needs little support provides good profits. Therefore, we are very restrictive regarding programming practices, with the idea that programs should be easy to read and maintain for perhaps two decades, even for someone who never learned the language used. The software should also be easy to mechanically translate from one language to another, should that be needed. In my experience, people that consider themselves software engineers dislike the restrictions. Their view seems to be that programming techniques and creativity in writing software matter, so restrictions are bad. Their view seems to be that a programmer is incompetent that does not know the programming language in detail. The people who have scientific backgrounds like the restrictions. They tend not to be concerned about creativity in programming, but more with product features and capabilities. They like being able to pick up a product written by someone else at the company years ago, and easily add a feature or rework something in it. They want to spend their time on features, such as improving the recording speed of an acquisition system, rather than learning what they consider obscure features of yet another transient computer language. For them, the more brain-dead obvious the code, the better. Dan Brown Tuesday, May 18, 2004 They are kind of hard to debug. With "if/else", the debugger steps on the line that is active. It's not really any harder to use "if/else" and it's easier to understand. Most ternary operators are documented quite well and consistent (I know C/C++ support the same facility, I think Java may be the same) across languages. I know I'd have a hard time working in an environment of "assembly line" programming - what makes me love my job is being creative and solving problems. I know that my falling in love with short, terse code isn't unique - it's the very roots of the definition hacker. I understand that what I write now will come back - the software we write now is going to be in existence probably for a decade so I consider it an act of responsibility to make things "understandable" and well documented.
html - programmers have less to do with "hard science" and more to do with creativity than one might initially think. David Seruyange Tuesday, May 18, 2004 In cases like this, I almost always use a function rather than a ternary expression. With a compiler that does inlining, you really don't pay anything in speed, so having the named function is generally a win. Chris Tavares Tuesday, May 18, 2004 How about: boolean isUp = eCommandName=="UP"; Russell Thackston Tuesday, May 18, 2004 Forget my last post, I like Chris' comments. Russell Thackston Tuesday, May 18, 2004 I don't agree that "saves space" is silly. I find that being able to see more code on my screen significantly helps my ability to comprehend it, whether I'm maintaining code or writing new code. For this reason, I favor the ternary operators for simple cases, such as the one presented; it occupies far less vertical space on the screen, leaving more room for the contextual code around it. Rob Warner Tuesday, May 18, 2004 I think ternary operators were great back in the days when when computers had < 8k of memory and ran at 1mhz. I would bet that modern compilers, such as Microsoft's C# compiler generate the same IL code for an equivalent "if" statement. I strongly agree with njkayaker's comment about debugging, but if you want to save verticle space: int move; would be more readable IMHO madmax Tuesday, May 18, 2004 So, combining Chris and Russell, we get: int move = GetMoveAmount( eCommandName ); int GetMoveAmount(char *cmd) { boolean isUp = cmd =="UP"; It might be fun to do a study and see what percentage of ternary operator uses do K&R style bracing. My bet is ternary users tend to do K&R, and non-ternary do Allman. I also bet non-ternary users tend to do huge, beautifully formatted function comments. String @return boolean @author Joe Horker @last_modified January 17th, 2004, 1:02 PM This function takes a String, 's', and returns true if it equals "true" and false if it equals "false". and prone to side effects long term, which might be good or bad. mb Tuesday, May 18, 2004 Brad, good point, bad example on my part. It is far easier to read and I don't have to go treking off to some other function tto find out what the heck is going on. Dennis Atkins Tuesday, May 18, 2004 GetMoveAmount( eCommandName ); The only time I like the ternary operator is in this form: ( ? c : d) And only if it fits cleany in about 40 characters or less. So the first example at the top would be ok if you added parens to make it more obvious. NathanJ Tuesday, May 18, 2004 Of course, the name GetMoveAmount was just what I came up with after only seeing the one expression; hopefully in a real application the function could be named something that fit better with the problem domain. I still say that having a named function rather than an anonymous (and potentially complicated) expression is the way to go. I did not know so many people were just a priori against the ternary operator. I tend to use what makes the most sense to me at the time. One thing I NEVER do is if joe do this rather if(joe){ do } or if it's an assignment and simple: a = true === true ? But that does not mean I ALWAYS use the ternary operator. Personally I happen to like the ternary and I dislike code that is verbose. Don't make a mistake of substituting verbosity for clarity. I think what is true in writing prose is the same in programming. I strive to always put comments which say what I want to do as opposed to describing what I am going to do as that is right in front of your eyes. I think that if I write unobfuscated code yet terse then I or anyone else will understand it quicker. I have taken some code and just erased all the comments and the line breaks and only then would I work on it as I don't like stuff which just gets in the way as code with too many comment always tends to do imho. There are some cases where the ternary operator is required (at least in C++). If you're reference happy (and who isn't), then you can use a ternary operator like this: const string &str=bCondition ? It would be difficult to affect the value of the reference any other way (if-else wont work; Ternary is a fact of life in a C syntax derived language. Prohibiting its use out-right on a project feels akin to prohibiting the use of contractions in English writing.
Anonymouche Tuesday, May 18, 2004 Yep, as that points out, a very common and useful use for these things is small chunks of boring string-building code that really shouldn't take up much s...
|